Page 2 of 2 FirstFirst 12
Results 16 to 20 of 20
  1. #16
    Join Date
    Sep 2010
    Location
    PNW
    Posts
    13,262
    Downloads
    0
    Uploads
    0
    Used 3 additional mags, same problems. Won't extract. Will try another non-Radical BCG next time. So far this upper has been a bust. You get what you pay for.

  2. #17
    Join Date
    Aug 2014
    Location
    Mn.
    Posts
    1,222
    Downloads
    0
    Uploads
    0
    When you get the fired round out of the chamber does it have extractor marks?
    The best way to survive a violent encounter is to be the one inflicting the most violence.

  3. #18
    Join Date
    Sep 2013
    Location
    WA
    Posts
    3,751
    Downloads
    1
    Uploads
    0
    Quote Originally Posted by Stone View Post
    When you get the fired round out of the chamber does it have extractor marks?
    I was curious as well


    Uw - before you swap bcgs , maybe swap the extractor spring and/ or insert or o-ring

    I’ve swapped in a few bcm extractor springs/ Black inserts in some finicky rifles and it seemed to fix it

  4. #19
    Join Date
    Aug 2014
    Location
    Mn.
    Posts
    1,222
    Downloads
    0
    Uploads
    0
    Quote Originally Posted by mustangfreek View Post
    I was curious as well


    Uw - before you swap bcgs , maybe swap the extractor spring and/ or insert or o-ring

    I’ve swapped in a few bcm extractor springs/ Black inserts in some finicky rifles and it seemed to fix it
    Exactly!
    The best way to survive a violent encounter is to be the one inflicting the most violence.

  5. #20
    Join Date
    Sep 2010
    Location
    PNW
    Posts
    13,262
    Downloads
    0
    Uploads
    0
    So after I had initial issues with this project, I took it out twice more since the last update. I know it's been awhile, but I've been zero'ing a lot of other guns, so it's taken a back seat.

    I've shot another 320 rounds through the upper and the last 260 rounds have been trouble free. I'm going to attribute this to a break in period for this upper. I haven't done anything to trouble shoot it as far as swapping BCG's, extractor springs, ect. I took it apart after my initial troubles and thoroughly cleaned and lubed everything. I then reassembled and still had some sporadic issues.

    I again cleaned and lubed everything and the last 8 mags or so have been trouble free. I'll take it out a few more times to see if the upper continues to function correctly. The only variable I changed was I used 2 fresh out of the wrapper Magpul MOE PMags.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •